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I. Introduction         

 Introductions 

 Housekeeping 
o Location of restrooms 
o Length of class is 2 hours 
o You’re encouraged to questions during class 
o Reminder– resources for further study listed at end of this document 
o Feel free to sit back and watch if the class is too advanced. 

 

 

II. Class Learning Objectives 

By the end of this class, you will be able to: 

1. Recall basic Excel terminology 
2. Create and revise simple formulas 
3. Use mathematical operators in formulas using PEMDAS order 
4. Define absolute and relative cell references 
5. Use mathematical, logical, date, and text functions  
6. Apply conditional formatting to data 
7. Use Sort & Filter tools 
8. Create and edit tables  
9. Insert and edit charts 

 

 

III. Review of Common Terminology 

 

 BRIEF review tabs in the Ribbon  
 

o Home Tab – the default tab all of the Office software opens to. It has your most 
commonly accessed features. 
 

o Formula Tab – Houses the function library. You can browse to see what other 
functions exist in the Excel. 
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 Navigating Excel  
 

o Row 
 

o Column 
 

o Cell 
 

o Cell Address or reference 
 

o Formula Bar 
 

o Workbook 
 

o Worksheet 
 
 
 

IV. Creating Formulas 

 

 Remember that Excel only understands a formula written with the equal sign first.  

 

 Excel's formulas look like a backwards version of an equation. 
 

 Instead of referencing actual values - or numbers - in a formula, we are going to 

reference the cells those values are in.  Such as =A1+B1 (the number located in cell A1, 

which means row 1, column A) plus the number in cell B1 (which means row 1, column 

B) 

 

 Excel adds whatever values happens to be in those cells instead of the precise values. 

That way, if the values change, the total updates automatically. 

 

 

Activity: Create a basic formula in Excel. 

 Open the Practice Workbook file in the Class Materials folder on the desktop. 

 

 Click on Practice worksheet tab. 
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 How would we add the values in cells A1 – F1 together? 

 

o Click in cell G1. 

 

o Type in =. 

 

o Click on A1, type a plus (+), then click on cell B1, and repeat for cells C1 through 

F1 until you have this formula: 

 =A1+B1+C1+D1+E1+F1 

 Note we don’t have a value in the cell yet. This is because the formula 

hasn’t been confirmed. 

 

o Press ENTER. 

 

 Remember formulas will update our total automatically updated to reflect any changes 

to values located in the cells referenced in the formula.  

o This is because instead of referencing a specific value, we are asking Excel to 

add whatever value is in the cell to the rest of the cells. That way, when values 

change, our totals are automatically updated. 

 

 Review the formula. 

o Click on cell G1. We still only see the total.   

 

o Note we can review the formula in the formula bar located above the 

spreadsheet. This is how we can troubleshoot problems we have with formulas 

that aren’t behaving the way we expect! 

 

 

V. Order of Operations 

o Math is amazing, but we need to make sure Excel is performing our calculations 

in the order we need it to. 

 

o Stay in Practice worksheet 
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Activity: 

 Excel doesn’t just perform operations in the order they are typed in. There is a hierarchy 

to how operations are performed. We need to tell Excel what order we want it to go in. 

o An easy way to remember the order of operations is “Please Excuse My Dear 

Aunt Sally”.  

 P=Parenthesis  ( ) 

 E=Exponents  ^ 

 M=Multiplication  * 

 D=Division  / 

 A=Addition  + 

 S=Subtraction  - 

 

o If you need Excel to perform addition before division, you need to put parenthesis 

around the values that are added first. 

 

 You may get the wrong results if you forget the order of operations.  Type the following 

into empty cells and explain: 

Ex: 

1+2+3*5= 18  or 3 + 15 

Vs. 

(1+2+3)*5=30 or 6*5 

 

 

Activity: Play with PEMDAS 

 

 Let’s say we want to determine the result of dividing the total of A2 minus B2 from the 
total of C2 and D2. 

o In an empty cell, type =A2-B2/C2+D2 
 The symbols in the upper right corner of the 10 key pad are your 

mathematical functions.  You may need to press NUM LOCK to activate 
the key pad. 

 With this formula, Excel will perform B2/C2 first.  

 Now revise the formula in the formula bar by adding the appropriate parentheses.  
=(A2-B2)/(C2+D2) 

o What happened to our value when we just added parenthesis? 
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VI. Using Functions  

 

a. Mathematical functions – AutoSum and Average  

 Click on the Auto Inventory worksheet. 

 

 We are going to create a summary of some information of what’s going on with our car 

lot. 

 

 We’ve looked at adding short lists of numbers together, but not all the values we want to 

add will be short lists.  

 

 Excel has shortcuts to help us with math so we don’t have to do as much work! 

 

Activity: Review of AutoSum function 

o Click in cell E33 (just below the list of prices). 

 

o Click on the AutoSum button on the Home Tab 

 

o Press ENTER. 

 

 Note that Excel automatically figured out which values we were talking about based on 

the active cell – the one we just clicked on, or E33. 

 

 Excel will automatically pick the set of contiguous values that are adjacent to where the 

AutoSum is inserted. 

 

 What happens if you didn’t put AutoSum adjacent to the values you want to add? 

 

 

Activity: Review of using AutoSum manually 

 Click in cell B35 

 

 Type in Total Inventory 

 

 Tab over to cell E35 
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 Click on the AutoSum button  

o Note that Excel didn’t know which values to add, because the cell isn’t adjacent 

to any numerical values. 

 

 Click in cell E2 and drag down to select all cells through E32 

o Note that you can always type in the values, but this can lend itself to more 

mistakes. 

 

 Press ENTER 

 

Activity: Explore Average function  

 Click in cell B36. 

 

 Type Average Price and tab over to cell E36 

 

 Hover on the AutoSum button. 

o Note that it is actually 2 buttons. Clicking on the Greek letter will automatically put 

in AutoSum, but if you click on the options arrow you see other commonly used 

functions. 

 

 Click on the AutoSum options button. 

 

 Select Average. 

o Note that because this is next to the Autosum data,  

it automatically tried to average AutoSum. We want the  

average of our inventory. 

 

 Click and drag to select E2:E33 

 

 Press ENTER. 
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b. Date Function 

 

 Stay in the Auto Inventory worksheet 

 

 Not all functions in Excel are math functions. 

 

 We want to determine how long each of the cars on our lot have been sitting there. 

 

 Before we can do that, we need to know today’s date. 

 

 Rather than type in the date every day (and potentially sometimes forget), we are going 

to use a function that will update with today’s date automatically every time we 

open the file. 

 

 I want today’s date to appear at the top of the worksheet, so I’m going to start by 

creating some space for it. 

 

Activity: Insert today’s date 

 Click on the row heading for row 1 

 

 Click on Insert (Cells Grouping, Home tab) 3 times to insert in 3 rows 

 

 Click in cell A1 

 

 Type Today’s Date: and tab over to cell C1 

 

 In C1, Type =TODAY() 

o Note that the function has the same elements as Autosum. 

o = sign 

o Function type (today) 

o Parentheses (which are necessary for every function, regardless of whether 

there is anything inside them) 

 

 Press ENTER 
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Activity: Let’s determine the age of the vehicles in our inventory by subtracting the date 

the car entered the lot with today’s date. 

 Click in cell G5 

 

 Type an equals = 

 

 Click on cell C1 

 

 Type a minus - 

 

 Click on cell F5 

 

 Press ENTER. 

o Question: Was there anything covered in Excel for Beginners that would help us 

to duplicate this formula down this entire column?  

 

 Grab the AutoFill handle and drag down several lines. 

o You will get an error message and wrong values.  

o This is because we need to understand ABSOLUTE AND RELATIVE VALUES! 

 

c. Absolute vs. Relative Values 

 

 Cell references are similar to street addresses. 

 

 An absolute reference is the exact address: Central Library is located at 4100 

Virginia Beach Blvd [or your branch library address]. 

 

 A relative reference is giving someone directions relative to a known location: go 

east for five blocks east of Town Center and the building is on the northwest corner. 

 

 

Relative Reference 

 A relative reference is a cell reference that adjusts automatically when the formula is  

copied to adjacent rows and columns.  Relative references are the default setting in 

Excel. 

o When you use Autofill or copy a formula down a column the row part of the 

formula will automatically adjust.   

o If you’re autofilling across a row, the column part of the formula will automatically 

adjust. 
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Absolute Reference 

 An absolute reference is a cell reference that won’t automatically adjust when the 

formula is copied to adjacent rows or columns.   

 

 An absolute reference never changes, no matter where you are in the city. The 

building address is still at 4100 Virginia Beach Blvd. 

 

 A relative reference changes depending on where you are. 3 blocks east, for 

example, only works if you are at Town Center. It doesn’t get you to the library if you are 

coming from Lynnhaven Mall. 

 

 The dollar symbol “$” tells Excel that a cell should be seen as a specific cell – or 

address - instead of as a relative reference. 

 

Switching Between Relative and Absolute Cell Formats 

There are four combinations to select from when you reference a cell. To cycle through the 

four formats, press function key F4. 

A1 Relative Reference - this is the default format in Excel. 

$A$1 Absolute Reference - both the column and row are absolute, or static. 

A$1 Mixed Reference - this format uses a relative column and an absolute (static) row. 

$A1 Mixed Reference - this format uses an absolute (static) column and a relative row 

 

 

Activity: Correct our formula so there is an absolute reference 

 Click in cell G5. 

 

 Click in the formula bar just before the C. 

 

 Type in a $ in front of both the C and the 1 (cell C1 has today’s date). 

o QUESTION: do we need to make F5 an absolute reference too? 

 No. We want to reference different values as we move down column F 

(the date each car entered the lot). That way we know the age of each car, 

not just the one car in row 5. 

 

 AutoFill down column G until the end of your inventory. 
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d. Logical Functions – COUNT  

 

 We’ve looked at some math functions and date functions as well as some just basic 

math. Well done! Now let’s look at some more complicated functions out there. 

 

 There are more details about our inventory that I’d like to include in the little summary at 

the bottom of our worksheet. 

 

 First, I’d like a running count of how many vehicles are currently on our car lot. 

 

 

Activity: Create a Count statement 

 Click in cell B40. 

 

 Type in ‘Number of Vehicles’ and tab over to cell D40. 

 

 Click on the options arrow next to AutoSum in the Ribbon.  

 

 Click on More Functions. 

 

 

 Click on Count in the Most Recently Used 

category and then click OK 

 

 Click and drag to select E5:E35. 

 

 Click OK. 

o Point out that if you add a new vehicle 

to the bottom of this list, it won’t be 

included in any of our formulas.  

o Sometimes it is worthwhile to include 

more cells in a formula than are 

currently needed in the spreadsheet. 

This allows for growth over time! 
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e. Text Functions – CONCATENATE 

 

 Let’s go to the Donors spreadsheet 

 

 There may be times when you may wish text from two or more columns or rows were 

combined into one. CONCATENATE will do this for you! 

 

 

 

Activity: Combine First Name and Last Name into a new column 

 

 Select column D – email addresses – by clicking in column header D. 

 

 Click Insert button in the Home Tab once to add a column to the left. 

 

 Click in cell D2.  

 

 

 Click Formulas Tab in the Ribbon. 

 

 

 Click TEXT button. 

 

 

 Select CONCATENATE. 

 

 Text1 field in the CONCATENATE Function 

Arguments pop up box will have a blinking cursor – 

click in B2 to select First Name data. 

 

 Click in Text2 field in the Function Arguments box. 

 

 Click C2 to select it. 

 

 Click OK – but is it OK?  

o =CONCATENATE(B2,B3) 

o NO – there’s no space between first name and last name. 
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 To correct this, we’ll revise the formula in the 

Formula bar!  

o Click in Formula bar and click after the first 

comma. 

o Type quotation mark “  

o Press spacebar once 

o Type another quotation mark “  

o Type a comma. 

o Press ENTER and review the results 

 

 Now we can use AUTOFILL to drag/copy the formula down to the last row in the 

spreadsheet. 

 

 

VII. Viewing Data 

 

a. Conditional Formatting  

 Let’s go back to the Auto Inventory worksheet. 
 

 Sometimes you want to use cell formatting to draw your attention to specific data. That 
data may change over time, so having Excel change the formatting automatically for us 
could be pretty cool. 
 

 When do you think it would be useful to see a cell automatically highlighted? 
 
 

Activity: Apply conditional formatting to inventory older than 45 days 
 

 Let’s say we want to see which cars have been on the lot for more than 45 days. We 
can do this by highlighting data based on that criterion. 
 

 Select cells G5 through G35 
 

 Click the drop-down menu on the Conditional Formatting 
button from Home Tab -> Styles group  
 

 Select Highlight Cells Rule 
o Note the other options available – greater/lesser, equals 

to, contains text, etc. Plus the Top/Bottom options and 
other visual styles (data bars, etc.) 
 

 Select Greater Than 
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 Type 45 and keep the default color (light red fill, dark red font) 
 

 Press OK 
 

 

b. Sorting Data 

 

Basic Sort   

 

 Let’s go back to the Donors worksheet. 
 

 A sort keeps all of the data on your worksheet visible, but organizes it either 
alphabetically or numerically.  
 

 There is a Sort & Filter group on the Data tab. However, we are going to use the Sort & 
Filter option on the Home tab today. 
 

 Click on the Home tab. 
 

 

Activity: Sort by Last Name 
 

 Click anywhere in the Last Name column. 
o Note that you click IN the column, you don’t select the column.  

 

 Click on the Sort & Filter button in the Editing grouping on the Home 
tab. 
 

 Click on Sort A to Z. 
o Note that it didn’t just sort that column; it moved all the rows to 

keep the information together, but organized your data 
alphabetically by last name. 
 

 Now click the Undo button to remove the sort. 
 

 QUESTION: How would you sort by Previous Contributions data from Smallest to 
Largest? Try it! 
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Custom Sort  
 

 Sorting allows you to sort all data based on what’s located in a single column or row.   
 

 What happens if you want to sort by multiple fields? E.G., what if I want to sort by Zip 
Code, but I want my contacts organized by Last Name within those Zip Codes? 

 

 

Activity: Perform a custom sort by Zip Code then by Last Name 
 

 Click anywhere in your data.   
 

 Click on the Sort & Filter button in the Editing grouping on the Home 
tab. 
 

 Click on Custom Sort. 
 

 Set your first sort to be done by Zip Code and organized smallest to 
largest. 
 

 Click on Add Level. 
 

 Set your second sort to be by Last Name and A 
to Z. 
 

 Click OK. 
 

 Click Undo button to remove the sort. 
 

 QUESTION: How would you do a custom sort by City then by Previous contributions? 
Try it! 
 

 Click Undo button when finished. 
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c. Filtering Data 

 

Checklist Filter 

 

 Stay on Donors worksheet. 
 

 A Sort arranges data but keeps it visible. What if you only want to see specific data? 
 

 Filters will hide some of your data from your view without actually deleting 
anything.  
 

 This is really useful for looking up information or only printing specific information in 
large worksheets. 

 

 

Activity: Create a filter to only show Denver residents  
 

 Click on the Sort & Filter button in the Editing grouping on the Home 
tab. 
 

 Click on Filter. 
o Note that all that changed were options arrows appeared next 

to each of our column headings. We only need to click on the 
filter button once to perform as many filters as we want. All the 
filter button on the ribbon does is turn on and off these options 
buttons. 
 

 

 Click on the options button next to City. 
 

 Click in the box next to Select All in the checklist portion of 
the dropdown to deselect all choices. 
 

 Click in the box next to Denver so it’s the only city selected. 
 

 Click on OK.  
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 Note our data is only showing people in our contacts list who live in Denver. 

o How do we know that the spreadsheet has been filtered:  a funnel icon  
appears next to the filter option on City; row numbers turned blue, row numbers 
missing from the list. 

o If someone filters a workbook and clicks save, the filter is saved as well. If you 
ever open a workbook that is missing data, first check to see if filters are turned 
on. 

 

 

Activity: Remove the filter 
 

 Click on the filter icon next to the City header. 
 

 Click on “Clear Filter from City” to Remove filter from 
City.  
 

 

 

VIII. Formatting Data as a Table 
 

 When you are looking at this much data in a spreadsheet, it can be hard to read.  
 

 Formatting your data as a table gives a visual element to the table that makes it prettier 
and easier to read. 
 
 

Activity  
 

 Stay in the Donors sheet. 
 

 Click anywhere in your data. 
 

 Click the Format as a Table button in the Styles group on the 
Home tab. 
 

 Select any of the formatting options  
o Note the different grouping: 

 Banded 
 Gridlines or no gridlines 
 Headers or no headers 
 Light, medium, dark 
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 Note the cell range in the pop up box and the “marching ants” 
border around the parameter of the data indicating  
where the formatting will be applied.  
 

 Click on OK. 
 

 Note the following: 
o Alternating row colors (for most table styles). 
o Table extends just as far as the text fields do. 

 Note that when you build worksheets, it’s best not to leave blank rows or 
columns between their data. If you do, Excel could miss information you 
want to include. 
 

 Note keyboard shortcut for formatting spreadsheet as a table is to click anywhere in 
data and then press CTRL + T and click OK. 
 
 

Activity: Play with the table formatting 
 

 Try expanding the table downward to incorporate more rows 
by dragging the border corner down. 
 

 Play with changing the table formatting using the Table Tools 
Design tab. 
 

 If you have time, play with the features in that tab. 
o Table Tools contextual tab: 

 Check box to add Total Row! 
 Change style in Table Styles group 

o Deselect Filter to remove option buttons from headers (filter buttons are active 
automatically with all table styles.) 

o Remove Duplicates 
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IX. Inserting a Chart 

 

 When is using a chart appropriate? When you want to visually represent data, you can 
use a chart. 
 

 Charts work best to report on 2 axes of information such as expenses per month or 
hours of leave taken per employee. 

 

 

Activity: Insert a chart showing the earnings for all stores last year. 
 

 Click the Sales worksheet tab. 
 

 Click anywhere in your data. 
o Note that if you select a cell without data in it, you will get a blank chart. Make 

sure you always start by clicking on the data you want to display. 
 

 Go to the Insert tab and select Chart (Excel 2010)  
 
 
 
 

 In Excel 2013, select a chart type from the Charts group in 
the Ribbon. 
 

 
 

 Take a minute to look at the various chart types available.  
 

 QUESTION: which of the chart types would work best for this question? 
o When in doubt, select a chart type and then hover over the different options to 

get a preview (Excel 2013) or the name (Excel 2010). Use that to see if it meets 
your needs. 
 

 Click on the chart types of your choice. 
o Note that we have contextual tabs that appear while we have the chart selected. 

If we click off the chart, the tabs go away. When we click on the chart, they 
reappear. The only time we have chart editing tools is when we have a chart 
selected. 
 

 Click on Change Chart Type in the Type group (Excel 2013) to change the way the 
chart looks.  

o In Excel 2010, select the Design Tab and then Change Chart Type. 
o Select the 2D column chart if chart isn’t in that format already and click OK.  
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Activity: Make the chart pretty by editing it 
  

 Remember to select (click on) a chart before 
editing  it. 
 

 Make the chart bigger using the handles on the 
corners.  
 

 Click on Chart Title and change to 2014 Store 
Earnings. 
 

 Hover over different layouts in the Chart Styles 
group to preview other options. 
 

 Click Change Color button in the Chart Styles group to preview other color options. 
 

 Click the plus in the upper right corner of the chart to demonstrate how to turn on and 
off features like Axis Title, Chart Title, Data Labels, etc. 
 

 Delete the chart by clicking in the blank space of the chart and pressing delete on the 
keyboard. 
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X. Wrap Up 
 

 Review what you learned today 
 

 Questions? 
 

 Resources for additional learning: 
 

o www.vbgov.com/tech-ed 
 Tech Help 
 Upcoming classes 

 

 Demonstrate Lynda.com: 
o Go to VBPL website: www.VBgov.com/libraries > Find Materials > Research & 

Articles > A to Z Resources 
o Scroll down and click on Lynda.com 
o Enter library card number and pin number into appropriate boxes 
o You will need to set up an account with your name and email 
o Locate Search bar across top of page and enter subject 
o Notice list of suggested courses in middle of page with course descriptions and 

related courses tab 
o Use filter options on the left side of page to narrow results by skill level and 

subject  
o Use + button to add courses to your playlist 

 

 Homework – if you would like to practice your new skills, play around with one of the 
templates in the File tab of the ribbon. You could download and work on budget, 
calculator, or inventory list worksheets. 
 

 Google – search for tips, for example: Microsoft Excel 2013 Pivot Tables 
 

 Please complete the evaluation form! 
 

 
 
 
 

Thank you for coming! 
 
 
 
 
 
 

Copyrigh: This work, "Microsoft Excel 2013 Intermediate," is a derivative of "Microsoft Excel: Formulas and Functions," “Microsoft Excel: Sort 
and Filter,” “Microsoft Excel: Advanced Formatting,” and “Microsoft Excel: Graphs and Pivot Tables” by the Denver Public Library, used under 
CC BY. "Microsoft Excel 2013 Intermediate” is licensed under CC BY by Virginia Beach Public Library. 
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